Авторский блог Фельк Виктора
Все секреты компьютера
для новичка и профессионала

Примеры использования функции СУММЕСЛИ в Excel

Автор:
Примеры использования функции СУММЕСЛИ в Excel
Примеры использования функции СУММЕСЛИ в Excel

Здравствуйте. Чаще всего мне приходится работать в текстовом редакторе Word, но периодически сталкиваюсь и таблицами. Они помогают организовать большие массивы данных и упрощают анализ. Есть очень полезная функция СУММЕСЛИ в Excel, примеры использования который мы сегодня рассмотрим, чтобы лучше понимать принцип её работы.

 

Синтаксис

Данная формула является более сложным вариантом обычного суммирования, в котором можно задавать определенные условия. Чтобы начать использовать, необходимо в итоговой ячейке таблицы поставить знак «равно» и ввести следующие значения:

=СУММЕСЛИ(диапазон; критерий; [диапазон сложения])

Давайте разберем это выражение:

  • Критерий является тем самым условием, от которого зависит выполнение функции;
  • Диапазон устанавливается для указания ограничений;
  • Диапазон сложения – это перечень всех ячеек, значения которых должны обрабатываться.
Аргумент, который указан в конце не является обязательным.

Практическое использование

Чтобы разобраться получше, как работает функция СУММЕСЛИ в Excel, примеры обязательны к рассмотрению. Допустим, у нас есть таблица, состоящая из следующей информации:

  • типа товара;
  • порядкового номера;
  • стоимости единицы;
  • Складского запаса.

Если необходимо вычислить общее количество товаров всех категорий, достаточно применить обычное суммирование. Но вдруг нам нужно узнать, сколько всего носков на складе, независимо от наименования? Если таблица большая, то выбирать вручную – работа неблагодарная. Лучше поступить следующим образом:

=СУММЕСЛИ(E6:E15;"носки";H6:H15)

  • E6:E15 – это диапазон типа товара;
  • «носки» — условие;
  • H6:H15 – ячейки суммы.

Суммирование по одному условию

В итоге мы имеем 35 пар носков на складе. Аналогично, мы могли бы указать любой другой тип (куртка, футболка), чтобы просмотреть количество этой одежды. Думаю, с этим несложно разобраться. Тем более, в конце поста будет видео.


А если условий много?

В этом случае используется формула СУММЕСЛИМН в Excel, примеры несколько условий которой мы сейчас рассмотрим.

Допустим, предстоит сосчитать, сколько курток со стоимость 500 имеется на складе. То есть, критериев уже несколько (тип одежды и цена). Формула будет иметь немножко иной вид:

=СУММЕСЛИМН(H6:H15;E6:E15;"куртка";G6:G15;500)

  • H6:H15 – диапазон суммирования (количество);
  • E6:E15 – ячейки первого крит-ия (тип одежды);
  • «куртка» — крит-ий №1
  • G6:G15 – ячейки второго крит-ия (стоимость);
  • 500 – крит-ий №2

Суммирование с несколькими условиями

Как результат, получаем 32 куртки с ценой в 500 условных единиц.

Обратите внимание, что указанные выше функции имеют динамический характер. То есть, если Вы через какое-то время добавите в таблицу несколько строк, то они могут оказать влияние на конечный результат. Это очень удобно, ведь вся работа приобретает автоматизированный характер. Вносите значения, а формула пересчитывает сумму.

Предлагаю посмотреть детальное видео по теме, чтобы лучше разобраться, как работает функция СУММЕСЛИ в Excel, примеры использования:

Вопросы и пожелания можете писать в комментарии.

С уважением, Виктор!

Скачать браузер Амиго бесплатно
Рубрика:
Офисные
Рейтинг:
  • 5
  • 4
  • 3
  • 2
  • 1
Поддержите проект в Facebook и получайте больше интересных постов каждый день↓
Это может быть так же интересным:
Оставить комментарий
Комментировать через: 

Ваш e-mail не будет опубликован. Обязательные поля помечены *